use strict;
my $str = '728,"H !A@Y,HAYE",Marie,François,RAUTUREAU,85,29/05/1856,68;';
my $regex = qr/,(?=[^"]+")/p;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";