const regex = /,(?=[^"]+")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(?=[^"]+")', 'g')
const str = `728,"H !A@Y,HAYE",Marie,François,RAUTUREAU,85,29/05/1856,68;`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);