#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ",(?=[^"]+")"
Local $sString = "728,"H !A@Y,HAYE",Marie,François,RAUTUREAU,85,29/05/1856,68;"
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)