import Foundation
let pattern = #",(?=[^"]+")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"728,"H !A@Y,HAYE",Marie,François,RAUTUREAU,85,29/05/1856,68;"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)