re = /,(?=[^"]+")/
str = '728,"H !A@Y,HAYE",Marie,François,RAUTUREAU,85,29/05/1856,68;'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result