#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "node_modules\/(?!react\-hot).*-loader.*"
Local $sString = "node_modules/react-hot-loader" & @CRLF & _
"node_modules/react-redux" & @CRLF & _
"node_modules/babel-loader" & @CRLF & _
"node_modules/css-loader" & @CRLF & _
"node_modules/sass-loader" & @CRLF & _
"node_modules/redux-loader"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")