using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"node_modules\/(?!react\-hot).*-loader.*";
string input = @"node_modules/react-hot-loader
node_modules/react-redux
node_modules/babel-loader
node_modules/css-loader
node_modules/sass-loader
node_modules/redux-loader";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}