import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "node_modules\\/(?!react\\-hot).*-loader.*";
final String string = "node_modules/react-hot-loader\n"
+ "node_modules/react-redux\n"
+ "node_modules/babel-loader\n"
+ "node_modules/css-loader\n"
+ "node_modules/sass-loader\n"
+ "node_modules/redux-loader";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}