$re = '/node_modules\/(?!react\-hot).*-loader.*/';
$str = 'node_modules/react-hot-loader
node_modules/react-redux
node_modules/babel-loader
node_modules/css-loader
node_modules/sass-loader
node_modules/redux-loader';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);