const regex = /node_modules\/(?!react\-hot).*-loader.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('node_modules\\\/(?!react\\-hot).*-loader.*', 'g')
const str = `node_modules/react-hot-loader
node_modules/react-redux
node_modules/babel-loader
node_modules/css-loader
node_modules/sass-loader
node_modules/redux-loader`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}