re = /node_modules\/(?!react\-hot).*-loader.*/
str = 'node_modules/react-hot-loader
node_modules/react-redux
node_modules/babel-loader
node_modules/css-loader
node_modules/sass-loader
node_modules/redux-loader'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end