using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w*)\,([\w,]+)\s([\w:.-]*)\s(.*)";
string input = @"L2TP,info,account mk_log: user vasya logged out from 192.168.0.2 via telnet";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}