$re = '/(\w*)\,([\w,]+)\s([\w:.-]*)\s(.*)/m';
$str = 'L2TP,info,account mk_log: user vasya logged out from 192.168.0.2 via telnet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);