package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w*)\,([\w,]+)\s([\w:.-]*)\s(.*)`)
var str = `L2TP,info,account mk_log: user vasya logged out from 192.168.0.2 via telnet`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}