re = /(\w*)\,([\w,]+)\s([\w:.-]*)\s(.*)/m
str = 'L2TP,info,account mk_log: user vasya logged out from 192.168.0.2 via telnet'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end