import re
regex = re.compile(r"(\w*)\,([\w,]+)\s([\w:.-]*)\s(.*)", flags=re.MULTILINE)
test_str = "L2TP,info,account mk_log: user vasya logged out from 192.168.0.2 via telnet"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")