const regex = /\d.\d{0,3}(?= A)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d.\\d{0,3}(?= A)', '')
const str = `</tr><tr><td>Current: </td><td>0.190 A</td></tr><tr><td>Power: `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}