import Foundation
let pattern = #"\d.\d{0,3}(?= A)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"</tr><tr><td>Current: </td><td>0.190 A</td></tr><tr><td>Power: "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}