$re = '/\d.\d{0,3}(?= A)/';
$str = '</tr><tr><td>Current: </td><td>0.190 A</td></tr><tr><td>Power: ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);