import re
regex = re.compile(r"\d.\d{0,3}(?= A)")
test_str = "</tr><tr><td>Current: </td><td>0.190 A</td></tr><tr><td>Power: "
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")