using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""[^\""]+\""";
string input = @"""112233""|""Roshan""|""25""|"" FAX 022 3987789 \| TEL 77766288892 \| abc ""|""Male""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}