// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\"[^\"]+\""#).unwrap();
let string = "\"112233\"|\"Roshan\"|\"25\"|\" FAX 022 3987789 \\| TEL 77766288892 \\| abc \"|\"Male\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}