re = /\"[^\"]+\"/
str = '"112233"|"Roshan"|"25"|" FAX 022 3987789 \\| TEL 77766288892 \\| abc "|"Male"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end