$re = '/\"[^\"]+\"/';
$str = '"112233"|"Roshan"|"25"|" FAX 022 3987789 \\| TEL 77766288892 \\| abc "|"Male"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);