import re
regex = re.compile(r"\"[^\"]+\"")
test_str = ("\"112233\"|\"Roshan\"|\"25\"|\" FAX 022 3987789 \\| TEL 77766288892 \\| abc \"|\"Male\"\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")