#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=[a-zA-Z])\s+(?=[a-z]*'\s*[a-z])"
Local $sString = "'What 's your name?','Isn 't it beautiful?'" & @CRLF & _
"" & @CRLF & _
"Jesus ' cross"" & @CRLF & _
"do n't"" & @CRLF & _
"sdsda sdsd' sdsd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")