const regex = /(?<=[a-zA-Z])\s+(?=[a-z]*'\s*[a-z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[a-zA-Z])\\s+(?=[a-z]*\'\\s*[a-z])', 'g')
const str = `'What 's your name?','Isn 't it beautiful?'
Jesus ' cross"
do n't"
sdsda sdsd' sdsd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}