import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[a-zA-Z])\\s+(?=[a-z]*'\\s*[a-z])";
final String string = "'What 's your name?','Isn 't it beautiful?'\n\n"
+ "Jesus ' cross\"\n"
+ "do n't\"\n"
+ "sdsda sdsd' sdsd";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}