$re = '/(?<=[a-zA-Z])\s+(?=[a-z]*\'\s*[a-z])/';
$str = '\'What \'s your name?\',\'Isn \'t it beautiful?\'
Jesus \' cross"
do n\'t"
sdsda sdsd\' sdsd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);