using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[a-zA-Z])\s+(?=[a-z]*'\s*[a-z])";
string input = @"'What 's your name?','Isn 't it beautiful?'
Jesus ' cross""
do n't""
sdsda sdsd' sdsd";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}