re = /(?<=[a-zA-Z])\s+(?=[a-z]*'\s*[a-z])/
str = '\'What \'s your name?\',\'Isn \'t it beautiful?\'
Jesus \' cross"
do n\'t"
sdsda sdsd\' sdsd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end