package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.([^.]+)$`)
var str = `804269_General Motors Financial Company Inc._02-05-2020_10-K_0000804269-20-000006.txt.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}