$re = '/\.([^.]+)$/m';
$str = '804269_General Motors Financial Company Inc._02-05-2020_10-K_0000804269-20-000006.txt.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);