import re
regex = re.compile(r"\.([^.]+)$", flags=re.MULTILINE)
test_str = "804269_General Motors Financial Company Inc._02-05-2020_10-K_0000804269-20-000006.txt.txt"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")