// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\.([^.]+)$").unwrap();
let string = "804269_General Motors Financial Company Inc._02-05-2020_10-K_0000804269-20-000006.txt.txt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}