re = /\.([^.]+)$/m
str = '804269_General Motors Financial Company Inc._02-05-2020_10-K_0000804269-20-000006.txt.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end