#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?(DEFINE)(?'affix'd\.?b\.?a\.?))^(?P>affix)|(?P>affix)$"
Local $sString = "This doesn't match" & @CRLF & _
"Nor does D.B.A this" & @CRLF & _
"" & @CRLF & _
"But this does, DBA" & @CRLF & _
"As does this D.B.A." & @CRLF & _
"DBA this does" & @CRLF & _
"D.B.A and this does"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")