using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)(?'affix'd\.?b\.?a\.?))^(?P>affix)|(?P>affix)$";
string input = @"This doesn't match
Nor does D.B.A this
But this does, DBA
As does this D.B.A.
DBA this does
D.B.A and this does";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}