import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)(?'affix'd\\.?b\\.?a\\.?))^(?P>affix)|(?P>affix)$";
final String string = "This doesn't match\n"
+ "Nor does D.B.A this\n\n"
+ "But this does, DBA\n"
+ "As does this D.B.A.\n"
+ "DBA this does\n"
+ "D.B.A and this does";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}