const regex = /(?(DEFINE)(?'affix'd\.?b\.?a\.?))^(?P>affix)|(?P>affix)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)(?\'affix\'d\\.?b\\.?a\\.?))^(?P>affix)|(?P>affix)$', 'gmi')
const str = `This doesn't match
Nor does D.B.A this
But this does, DBA
As does this D.B.A.
DBA this does
D.B.A and this does`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}