$re = '/(?(DEFINE)(?\'affix\'d\.?b\.?a\.?))^(?P>affix)|(?P>affix)$/mi';
$str = 'This doesn\'t match
Nor does D.B.A this
But this does, DBA
As does this D.B.A.
DBA this does
D.B.A and this does';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);