re = /(?(DEFINE)(?'affix'd\.?b\.?a\.?))^(?P>affix)|(?P>affix)$/mi
str = 'This doesn\'t match
Nor does D.B.A this
But this does, DBA
As does this D.B.A.
DBA this does
D.B.A and this does'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end