# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*\b(particular phrase)\W+((?:\w+\W+){3}\w+).*$/\2/gm;t' <<< "Blah blah particular phrase Extract These Words Please for the blah blah. Ignore blah this other stuff blah blah, blah."