import Foundation
let pattern = #"^.*\b(particular phrase)\W+((?:\w+\W+){3}\w+).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Blah blah particular phrase Extract These Words Please for the blah blah. Ignore blah this other stuff blah blah, blah."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)