package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\b(particular phrase)\W+((?:\w+\W+){3}\w+).*$`)
var str = `Blah blah particular phrase Extract These Words Please for the blah blah. Ignore blah this other stuff blah blah, blah.`
var substitution = "\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}