const regex = /^.*\b(particular phrase)\W+((?:\w+\W+){3}\w+).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\b(particular phrase)\\W+((?:\\w+\\W+){3}\\w+).*$', 'gm')
const str = `Blah blah particular phrase Extract These Words Please for the blah blah. Ignore blah this other stuff blah blah, blah.`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);