using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\b(particular phrase)\W+((?:\w+\W+){3}\w+).*$";
string substitution = @"\2";
string input = @"Blah blah particular phrase Extract These Words Please for the blah blah. Ignore blah this other stuff blah blah, blah.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}