using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!0$)((1\d|2[0-4]|\d)?\d{1,3}|25000)$";
string input = @"123
0
1
9
10
50000
25001
25000
24999
24001
19999
555
23
20000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}