import re
regex = re.compile(r"^(?!0$)((1\d|2[0-4]|\d)?\d{1,3}|25000)$", flags=re.MULTILINE)
test_str = ("123\n"
"0\n"
"1\n"
"9\n"
"10\n"
"50000\n"
"25001\n"
"25000\n"
"24999\n"
"24001\n"
"19999\n"
"555\n"
"23\n"
"20000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")