import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!0$)((1\\d|2[0-4]|\\d)?\\d{1,3}|25000)$";
final String string = "123\n"
+ "0\n"
+ "1\n"
+ "9\n"
+ "10\n"
+ "50000\n"
+ "25001\n"
+ "25000\n"
+ "24999\n"
+ "24001\n"
+ "19999\n"
+ "555\n"
+ "23\n"
+ "20000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}